Creating a versioned WPAR

You can create a new versioned WPAR with the mkwpar command.

Note: The mkwpar command is not supported on a system that has Trusted Computing Base (TCB) installed.

Each WPAR has an isolated network environment with unique IP addresses and a unique host name. You can access WPARs through standard networking programs, such as telnet, FTP, and rlogin (depending on the services running in the WPAR). Before you create a WPAR, you must log in as the root user and perform one of the following prerequisites:

  • Select a name for the WPAR that maps to an IP address for your network.
  • Add an entry for the new versioned WPAR to the /etc/hosts file on the server. The entry must include the host name for the WPAR and the name of the WPAR:

    9.3.18.10 WPARname.austin.ibm.com WPARname

To create a new versioned WPAR, complete the following steps.
  1. Verify that the network recognizes your workload partition address by entering the following command:
    host WPARname

    The return looks similar to the following:

    WPARname.austin.ibm.com is 9.3.18.10, Aliases: WPARname

    To create a versioned WPAR you must have a stand-alone system running a supported version of AIX® (5.2 with Technical Level (TL)10, Service Pack (SP) 8 or 5.3 with Technical Level (TL) 12 or later) and a set of applications that you want to move to a WPAR

  2. Create a mksysb image of an AIX 5.2 or an AIX 5.3 system that provides the content for your versioned WPAR:
    mksysb -i /mksysb_images/backupname

    Make the backup image accessible from the target system where the versioned WPAR is to be created. This can be remote access as with an NFS mount, or the backup image can be copied to the target system. The bos.wpars package must be installed on the target system.

  3. Install versioned WPAR SMIT, and required installation images from the installation media. Example, using NIM:

    nimclient -o cust -a lpp_source=wparlppsource -a installp_flags=aXY -a filesets="vwpar.images vwpar.sysmgt"

    An example from command line: installp -qaXYd installation_device vwpar.images vwpar.sysmgt

  4. Configure the WPAR by running the following command:

    mkwpar -n WPARname -C -B /mksysb_images/backupname

    The initial output of the mkwpar command looks similar to the following:
    mkwpar: Extracting file system information from backup...
    mkwpar: Creating file systems...
     /
    Creating file system '/' specified in image.data
     /bff
    Creating file system '/bff' specified in image.data
     /home
    Creating file system '/home' specified in image.data
     /opt
    Creating file system '/opt' specified in image.data
     /proc
     /tmp
    Creating file system '/tmp' specified in image.data
     /usr
    Creating file system '/usr' specified in image.data
     /var
    Creating file system '/var' specified in image.data
    Mounting all workload partition file systems.
    New volume on /mnt/my52backup.bff:
     Cluster 51200 bytes (100 blocks).
        Volume number 1
        Date of backup: Wed Sep  9 13:50:34 2009
        Files backed up by name
        User root
    x         5477 ./bosinst.data
    x         7931 ./image.data
    x        55973 ./tmp/vgdata/rootvg/backup.data
    x            0 ./bff
    x            0 ./bff/lost+found
    x            0 ./opt
    ...
    It continues restoring all files from the mksysb image. Each system WPAR has an isolated section of the system's file space configured for the root directory, the /home directory, the /usr directory and other file systems. Creation and configuration of this space is reflected in the above output from the mkwpar command. After restoring all the files, the output from the mkwpar command then continues with the installation of several file sets into the WPAR. At the end of the installation phase, you can see an output similar to the following (The sample output shown below is from creation of an AIX 5.2 WPAR):
    installp: APPLYING software 
    for: vwpar.52 7.1.0.0 .
            . .
    
    
    . . << Copyright notice  for vwpar.52 >> .  . . . . . . Licensed
     Materials - Property of IBM 
    
     Copyright
       International Business Machines Corp. 2010. All
    
     rights reserved. US
     Government Users Restricted Rights - Use, duplication or disclosure restricted
     by GSA ADP Schedule Contract with IBM Corp. .
    . . . . <<  End of copyright notice for cre.base >>. . . .
    
    Finished processing all filesets.  (Total time:  29 secs).
    
    +-----------------------------------------------------------------------------+
                                    Summaries:
    +-----------------------------------------------------------------------------+
    
    Installation Summary
    --------------------
    Name                        Level           Part        Event       Result
    -------------------------------------------------------------------------------
    bos.wpars                   7.1.0.0         USR         APPLY       SUCCESS
    bos.wpars                   7.1.0.0         ROOT        APPLY       SUCCESS
    wio.common                  7.1.0.0         USR         APPLY       SUCCESS
    wio.common                  7.1.0.0         ROOT        APPLY       SUCCESS
    vwpar.52                    7.1.0.0         USR         APPLY       SUCCESS
    vwpar.52                    7.1.0.0         ROOT        APPLY       SUCCESS
    Workload partition WPARname created successfully.
    mkwpar: 0960-390 To start the workload partition, execute the following as root: 
     startwpar [-v] 'WPARname'  
    The configuration of the system WPAR is now complete.
  5. Start the WPAR by using the startwpar command.