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Chapter 1. Troubleshooting and support

Welcome to IBM® Host Access Transformation Services (HATS) Troubleshooting
guide. This guide provides information to assist you with problems you might
experience, including problems with product installation, building a project, and
deploying and executing an application in a production environment. This guide is
designed to serve as a self-help tool to help you resolve your problem without the
need to engage IBM support. It includes overview information about how to
troubleshoot a problem with HATS and instructions for searching for information,
downloading fixes, and getting technical support. If you do have to call IBM
support, this guide provides the information you need to help your IBM service
representative better diagnose and resolve your problem.

This book is not intended for use with the WebFacing feature of the HATS. For
information on troubleshooting WebFacing problems, see the product help after
WebFacing is installed.
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Chapter 2. Troubleshooting overview

Troubleshooting is the process of finding and eliminating the cause of a problem.
Whenever you have a problem with HATS, the troubleshooting process begins by
recording the issue as it occurred. A basic troubleshooting strategy at a high level
involves:
1. “Recording the symptoms of the problem”
2. “Recreating the problem”
3. “Eliminating possible causes” on page 4

Recording the symptoms of the problem
Depending on the type of problem you have, you might receive a message that
indicates something is wrong. Always record the error message that you see. As
simple as this sounds, error messages sometimes contain cryptic codes that might
make more sense as you investigate your problem further. You might also receive
multiple error messages that look similar but have subtle differences. By recording
the details of each one, you can learn more about where your problem exists.

The HATS Messages book provides explanations and user actions for error
messages. Refer to the HATS Messages book to access error code information.

Recreating the problem
Think back to what steps you took that led you to the problem. Try those steps
again to see if you can easily determine a repeatable sequence of events to recreate
the error. If you can identify a repeatable test case, you will have an easier time
determining what solutions are necessary to correct the problem. Ask these
questions of yourself when approaching any error involving HATS.
v How did you first notice the problem?
v Did you do anything different that made you notice the problem?
v Is the process that is causing the problem a new procedure, or has it worked

successfully before?
v If this worked before what has changed? The change can refer to any type of

change made to the system, ranging from adding new hardware or software, to
configuration changes to existing software.

v What was the first symptom of the problem you witnessed?
v Were there other symptoms occurring around that point of time?
v Does the same problem occur elsewhere?
v Is only one machine experiencing the problem or are multiple machines

experiencing the same problem?
v What messages are being generated that could indicate what the problem is?
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Eliminating possible causes
To save time and narrow the scope of your problem, eliminate components that are
not causing the problem.

Some tools you can use are:
v The host terminal:

– Step through the host screens to verify navigation through the host
application is still as you expect.

– Use the Host Screen Preview tab to see how each screen will look in a
production environment.

– Play your macros to ensure they still recognize the host screens and correctly
navigate through the host application.

– For more information, see the section on using the host terminal in Getting
Started. Also see the chapter on macros and the host terminal in the HATS
User's and Administrator's Guide.

v The project settings editor:
– Open the project editor to confirm the project-wide settings.
– Use the Events tab to ensure that the order of screen events is not causing the

problem. Maybe a new screen event you just added is not being recognized
because of another event higher in the priority list. Using the check boxes,
you can enable and disable events to see what effects they have on your
running application.

– For information about modifying a HATS project see the HATS User's and
Administrator's Guide

v The screen event editor:
– Screen Customizations display the Screen Recognition Criteria tab while the

Screen Combinations display Begin Screen and End Screen tabs. Use the
appropriate tab to check that the screen recognition criteria are still being met
for your screen events based on any changes that might have occurred on the
host screen.

– Use the Actions tab to check the actions to perform when the screen event is
recognized. Actions can be enabled or disabled. To enable an action, select the
check box. To disable an action, clear the check box.

– Use the Global Rules and Text Replacement tabs to confirm your settings
based on any changes that might have occurred on the host screen.

– For more information, see the information about using the screen event
editor in the HATS User's and Administrator's Guide.

v The display terminal:
– Use the display terminal while testing your project in the Rational® SDP

internal test environment to watch your project interact with the host. Seeing
what is happening during run time can be very helpful in debugging macro
and screen recognition problems.

– For more information, see the information about previewing your project in
Getting Started.

These tools are just some of the methods to use to help determine what might be
the cause of your problem. For more information, search knowledge bases to find
topics related to your problem, to determine if anyone else has experienced the
problem, and to learn if a fix is available. See Chapter 3, “Searching for
information” and Chapter 4, “Getting fixes” for more information.
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Chapter 3. Searching for information

If you have a problem with HATS, you want it resolved quickly. Begin by
searching the available knowledge bases to determine whether the resolution to
your problem is already documented.
1. “Search the IBM Knowledge Center.”
2. “Search the Internet.”
3. “Use the IBM Support Assistant” on page 6.

Search the IBM Knowledge Center
IBM provides extensive documentation on IBM Knowledge Center at
http://www.ibm.com/support/knowledgecenter/SSXKAY_9.6.0. An information
center can also be installed on your local machine or on a local intranet.

The Knowledge Center contains documentation from the HATS release notes and
all of the books in HATS library. HATS frequently asked questions, API reference
(Javadoc), and tutorials are included as well as links to Web sites for HATS
supported hardware and software requirements, support site, service updates,
technotes, education, and more. You can use the Knowledge Center to query
concepts and reference information as well as detailed instructions for completing
tasks.

Search the Internet
In addition to link to the IBM Knowledge Center, other links that might help you
resolve your problem are as follows:
v HATS Web site

http://www.ibm.com/software/products/us/en/rhats
v HATS support page

http://www.ibm.com/support/entry/portal/overview/software/rational/
rational_host_access_transformation_services
The HATS support page also provides links to the following types of
documentation:
– Fixes
– Downloads
– Flashes
– Technotes
– Documentation
– Problem Reports
– Training and certification

v HATS HotSpot
https://www.ibm.com/developerworks/mydeveloperworks/groups/service/
html/communityview?communityUuid=2ce1fd8d-d706-4afd-b9ef-9000ad21218d
The HATS HotSpot includes the following types of information and more:
– Blogs
– Forums
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– Resource library
v IBM developerWorks®

http://www.ibm.com/developerworks
v Internet search engines (for example Google)

http://www.google.com

Use the IBM Support Assistant
IBM Support Assistant (ISA) is a free local software serviceability workbench that
helps you resolve questions and problems with IBM software products.

HATS provides a plug-in for ISA V4.x. The HATS plug-in provides links to the
HATS Knowledge Center, home page, HotSpot, support site, and other sites. You
can search these sites for information that might help you resolve a problem.

ISA can be downloaded from http://www.ibm.com/software/support/isa. After
downloading ISA, unpack (that is, unzip) the files. Then, run the ISA installation
program.

To install the HATS ISA plug-in:
1. Start ISA.
2. Click Update > Find new > Product Add-ons from the menu bar.
3. The Find New Product Add-ons wizard is displayed.
4. From the Product Add-ons to Install page, expand Rational.
5. Find and select IBM Host Access Transformation Services V9.6 in the list.
6. Click Next.
7. On the Tools Add-ons to Install page, click Next.
8. On the Licenses of Add-ons to Install page, select I accept the terms in the

license agreements, click Next.
9. On the Summary page, click Install.
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Chapter 4. Getting fixes

A product fix might be available to resolve your problem. To determine what fixes
are available, go to the HATS support site at http://www.ibm.com/support/
entry/portal/overview/software/rational/
rational_host_access_transformation_services to look for support downloads.

You can receive notifications about fixes and other news about IBM products. For
information about subscribing for notifications, see "About My notification" at
http://www.ibm.com/support/docview.wss?uid=swg21460904.

You can also start the IBM Installation Manager and click Update to find available
fixpacks. For more on how this is done, see Updating the HATS Toolkit installation
in the HATS Getting Started book.

For information about types of fixes, see the Software Support Handbook at
http://www14.software.ibm.com/webapp/set2/sas/f/handbook/home.html. For
search help, visit the IBM Software Support Web site at http://www.ibm.com/
support/entry/portal/Overview/Software/Software_support_(general).

© Copyright IBM Corp. 2003, 2017 7

http://www.ibm.com/support/entry/portal/overview/software/rational/rational_host_access_transformation_services
http://www.ibm.com/support/entry/portal/overview/software/rational/rational_host_access_transformation_services
http://www.ibm.com/support/entry/portal/overview/software/rational/rational_host_access_transformation_services
http://www.ibm.com/support/docview.wss?uid=swg21460904
gsinstal.htm#update
http://www14.software.ibm.com/webapp/set2/sas/f/handbook/home.html
http://www.ibm.com/support/entry/portal/Overview/Software/Software_support_(general)
http://www.ibm.com/support/entry/portal/Overview/Software/Software_support_(general)


8 IBM Host Access Transformation Services: Troubleshooting



Chapter 5. Contacting IBM Software Support

IBM Software Support provides assistance with product defects.

Before contacting IBM Software Support, your company must have an active IBM
software maintenance contract, and you must be authorized to submit problems to
IBM. The type of software maintenance contract that you need depends on the
type of product you have:
v For HATS, enroll in Passport Advantage® in one of the following ways:

– Online: Go to the Passport Advantage Web page at http://www.ibm.com/
software/lotus/passportadvantage/ and click How to Enroll.

– By phone: For the phone number to call in your country, go to the contacts
page of the Software Support Handbook at http://www14.software.ibm.com/
webapp/set2/sas/f/handbook/contacts.html and under Worldwide contacts
click the name of your geographic region.

v You might purchase a software maintenance agreement by working directly with
an IBM sales representative or an IBM business partner. For more information go
to the "Support for IBM Systems" web page at http://www.ibm.com/systems/
support/.

If you are not sure what type of software maintenance contract you need, call
1-800-IBMSERV (1-800-426-7378) in the United States or, from other countries, go to
the contacts page of the Software Support Handbook at http://
www14.software.ibm.com/webapp/set2/sas/f/handbook/contacts.html and under
Worldwide contacts click the name of your geographic region for phone numbers
of people who provide support for your location.

Follow the steps in this topic to contact IBM Software Support:
1. “Determine the business impact of your problem”
2. “Describe your problem and gather background information” on page 10
3. “Submit your problem to IBM Software Support” on page 13

Determine the business impact of your problem
When you report a problem to IBM, you will be asked to supply a severity level.
Therefore, you need to understand and assess the business impact of the problem
you are reporting. Use the following criteria:

Severity Business impact

1
Critical: You are unable to use the program, resulting in a critical impact on
operations. This condition requires an immediate solution.

2 Significant: The program is usable but is severely limited.

3 Some: The program is usable with less significant features (not critical to
operations) unavailable.

4
Minimal: The problem causes little impact on operations, or a reasonable
circumvention to the problem has been implemented.
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Describe your problem and gather background information
When explaining a problem to IBM, be as specific as possible. Include all relevant
background information so that IBM Software Support specialists can help you
solve the problem efficiently. To save time, know the answers to these questions:
v What software versions were you running when the problem occurred?
v Do you have logs, traces, and messages that are related to the problem

symptoms? IBM Software Support is likely to ask for this information.
v Can the problem be recreated? If so, what steps led to the failure?
v Have any changes been made to the system? For example, hardware, operating

system, networking software, and so on.
v Are you currently using a workaround for this problem? If so, please be

prepared to explain it when you report the problem.

Gathering problem determination information
You might require assistance when determining the cause of HATS-related
problems. To gather general information for HATS support personnel, on the HATS
Toolkit menu bar, click HATS > Gather Problem Determination Information to
launch the wizard.

When the wizard opens, all projects are listed within the window. You can select
any combination of project types. Select the projects you want to include for
diagnosis by selecting the check box beside them. Specify the location of the zip
file you want to use to capture your information, then click Finish. The
information contained in the zip file assists HATS support personnel in
determining the cause of your problem.

For rich-client applications, click File > Preferences... > HATS > Troubleshooting
from the menu bar. The Troubleshooting window opens and you can select tracing
and logging settings. Click Gather to gather information required for diagnosing a
problem. The contents of the selected applications, the runtime extension plug-in,
and the .log file are copied into a zip file.

Note: For more information about tracing and logging settings for rich-client
applications, see Troubleshooting preferences in the HATS User's and
Administrator's Guide.

More specific information might be required for certain problem scenarios. To see
what specific information to gather, go to the HATS support site at
http://www.ibm.com/support/entry/portal/overview/software/rational/
rational_host_access_transformation_services. In the Search support and
downloads edit box enter mustgather and click the arrow button. Read the
technote titled MustGather: Read first for all Rational Host Access Transformation
Services products. Then scan the other technotes for those that might be related to
your problem scenario.

Displaying the Java Console
When using a Java™-enabled browser the Java Console or Java Log displays
information about Java events. The Java console is useful when asynchronous
update is configured. HATS messages and trace data can be shown here.
v “Displaying the Java Console in Internet Explorer” on page 11
v “Displaying the Java Console when running the Java 2 plug-in” on page 11
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Displaying the Java Console in Internet Explorer
Display options for Internet Explorer vary according to how it is configured. The
following are suggested ways to display the Java Console but they may not apply
to your browser.

To display the Java Console while using the Internet Explorer browser, do the
following:
1. Select Tools > Internet Options from the main menu bar.
2. Click the Advanced tab.
3. Scroll down to the Microsoft VM section and click in the checkbox next to Java

console enabled to enable the Java Console. (This requires you to restart the
browser.)

4. Click Apply.
5. Click OK.
6. Stop Internet Explorer as well as any other open instances of the browser and

restart it.
7. Select View > Java Console from Internet Explorer's main menu to view the

Java Console. The Java Console window appears.

If Internet Explorer browser does not provide the Microsoft VM selection on the
Advanced tab, do the following:
1. Select Tools > Sun Java Console option.
2. The Java Console window appears.

Displaying the Java Console when running the Java 2 plug-in
To display the Java Console when running the Java 2 plug-in, click the Java
Console option from the browser's Tools menu. Older versions of the plug-in
might require the selection to be made in the plug-in's control panel.

Worksheet for preparing to call IBM Support
If you determine that you need IBM assistance to solve a problem with HATS, then
complete this IBM support checklist for HATS. The following is a list of the
information that the IBM Support Center might need to help diagnose your
problem. You can print a copy of this list, and then fill in the blanks, before
contacting IBM for support.

Description of the problem and the environment
1. Problem Summary:

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

2. HATS version, release, and refresh pack level:
_______________________________________.
To determine the HATS version, do the following:
v Select Help on your IBM Rational Software Delivery Platform toolbar.
v Select About IBM Rational Software Delivery Platform.
v In the About IBM Rational Software Delivery Platform window, click

Installation Details.
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v In the About IBM Rational Software Delivery Platform Installation Details
window, click the Features tab. There are header bars for the following
items:
– Provider
– Feature Name
– Version
– Feature Id

v Click the Feature Name header bar to sort the features alphabetically.
v Scroll down in the list until you find HATS Core and HATS Toolkit.

3. Rational Software Delivery Platform (Rational SDP) product, version, release,
and refresh pack level: _________________________

4. Type of connection being used: 3270____ 3270E____ 3270 print____ 5250____
5250W ____ 5250 print____ VT____

5. Code page being used: ____________________________
6. Steps to recreate:

_________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________

7. What type of security is being used? None_____ SSL _____
8. If security is being used, describe the environment (for example, applicable

servers, backend systems, Web servers)?
Questions 9 through 21 apply to HATS Web or Portlet applications:

9. Client operating system: __________________________________________
On Windows, open the Windows control panel and start the System
application.

10. Browser version used to run the HATS application:
Firefox: ________________
Internet Explorer: ________________
Other: ________________
To determine your browser version, select Help on the browser toolbar and
then select the About ... menu item.

11. Are you using Dojo widgets? _________ If so, which version? __________
12. WebSphere® Application Server version: ____________________________
13. WebSphere Application Server platform: ____________________________
14. WebSphere Portal Server version (if applicable):

____________________________
15. WebSphere Portal Server platform (if applicable):

____________________________
16. Are there any messages posted in the Java Console? See “Displaying the Java

Console” on page 10 for instructions on how to display the Java Console in
the Internet Explorer or other browsers.

17. Are there any entries in your HATS log or trace files?
18. Are there any messages in your WebSphere Application Server logs, Web

server logs, or Rational SDP logs?
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19. Does the problem occur regularly ______ or only occasionally? _________
20. If the problem occurs when the browser client is connected to a WebSphere

Application Server, does it also occur when you use Run On Server in the
HATS Toolkit? Yes _____ No _____

21. Are your HATS connections configured to use Web Express Logon? Yes ___.
No ___.
If Yes:
Network Security Plugin: ____________________________
Credential Mapper Plugin: ____________________________
Question 22 through 26 apply to HATS rich client applications:

22. Client operating system and version: ____________________________
23. Rich client platform and versions (for example, Eclipse Rich Client Platform

V3.7, Lotus Notes® V8.5.3, or Lotus® Expeditor Client V6.2.3):
________________________________________________
To determine the version, click Help>About from within the client
environment.

24. How was the application installed into the client environment (for example,
installed using Eclipse Update Site, installed using a Lotus Notes widget,
provisioned from Lotus Expeditor Server)?
________________________________________________

25. Does the same problem occur when the application is run on a local test
environment (that is, from within the development environment)? Yes_____
No _____

26. Are there any entries in your HATS log or trace files? Yes ___. No ___.

Submit your problem to IBM Software Support
You can submit your problem in one of two ways:
v Web site: Go to the "Service requests & PMRs" web page at

https://www.ibm.com/support/servicerequest/Home.action. Enter your
information into the appropriate problem submission tool.

v Phone: For the phone number to call in your country, go to the contacts page of
the Software Support Handbook at http://www14.software.ibm.com/webapp/
set2/sas/f/handbook/contacts.html and under Worldwide contacts click the
name of your geographic region.

If the problem you submit is for a software defect or for missing or inaccurate
documentation, IBM Software Support will create an Authorized Program Analysis
Report (APAR). The APAR describes the problem in detail. Whenever possible,
IBM Software Support will provide a workaround for you to implement until the
APAR is resolved and a fix is delivered.

IBM publishes resolved APARs on the IBM product support Web pages daily, so
that other users who experience the same problem can benefit from the same
resolutions. You can search for HATS related APARs on the HATS support site at
http://www.ibm.com/support/entry/portal/overview/software/rational/
rational_host_access_transformation_services.
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Appendix. Notices

This information was developed for products and services offered in the U.S.A.
IBM might not offer the products, services, or features discussed in this document
in other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service might be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right
might be used instead. However, it is the user's responsibility to evaluate and
verify the operation of any non-IBM product, program, or service.

IBM might have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement might not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM might make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM might use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

Intellectual Property Dept. for Rational Software
IBM Corporation
5 Technology Park Drive
Westford, MA 01886
U.S.A.

Such information might be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrates programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

If you are viewing this information softcopy, the photographs and color
illustrations might not appear.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at www.ibm.com/legal/copytrade.shtml.

Microsoft and Windows are trademarks of Microsoft Corporation in the United
States, other countries, or both.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.
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