Unable to run an online backup or restore operation
When you try to run a backup or restore operation, you receive an error message that a backup or checkpoint operation is in progress.
Symptoms
You see the following error message, regardless of whether you started a backup or checkpoint operation or not:
Error: a backup or checkpoint operation is in progress, please try again later.
Causes
If no backup or checkpoint operation is in progress, the Red Hat® OpenShift® user session token possibly expired during a previous online backup operation. This problem might prevent running a new backup or restore operation, and you might need to reset the backup and restore utility and run the backup or restore posthooks command.
If a backup or checkpoint operation is currently running, the operation might be taking a long time to complete.
Resolving the problem
Do the following steps:
- Log in to Red Hat
OpenShift Container Platform as a cluster
administrator.
${OC_LOGIN}Remember:OC_LOGINis an alias for theoc logincommand. - If a backup or checkpoint operation is in progress, wait for the operation to complete. Check
the status of the operation by running the following
command:
cpd-cli oadp tenant-backup list - If no backup or checkpoint operation is running, or the utility is stuck, reset the backup and
restore
utility:
cpd-cli oadp reset
Before you run a backup operation that you believe can take a long time to complete, run the
OC_LOGIN command to get a new token.
Run the IBM Software Hub OADP backup and restore utility in REST mode. In REST mode, you do not need to log in to the cluster. For more information, see IBM Software Hub online backup and restore to the same cluster with the OADP utility.