Restoring Cognos if Tivoli Common Reporting Version 3.1.1 update fails
If you attempted to update an existing Tivoli® Common Reporting to 3.1.1 and the installation failed, you can restore the Cognos® directory, that was backed up before updating.
Symptoms
Restore Cognos if application of the Tivoli Common
Reporting Version
3.1.1 fails.
Causes
If the
application of the Tivoli Common
Reporting Version
3.1.1 fails, verify whether the Common Reporting user interface is
working by running a report. If you are able to successfully run the
report, you do not need to restore the Cognos directory.
If you cannot run a report, then you can restore Cognos that
was previously backed up. The process to restore Cognos is
dependent on the operating system in the Tivoli Common
Reporting environment.
Remember: On Aix, Linux,
and Linux on System z® systems, the Cognos directory
is automatically backed up when you apply the fix pack. Due to a limitation
on Windows systems, you must
manually back up the directory before you apply the fix pack.
Resolving the problem
To restore Cognos on Windows, complete the following steps:
- Stop the Jazz™ for Service Management application server on which Tivoli Common Reporting is installed. See Stopping Jazz for Service Management application servers.
- Rename the current folder as follows:
- JazzSM_HOME\reporting\cognos to JazzSM_HOME\reporting\cognos_notWorking
- Copy the backed up reporting folder into the JazzSM_HOME\reporting\ folder.
- Start the Jazz for Service Management application server. See Starting Jazz for Service Management application servers.
- Verify whether the Common Reporting user interface is working
by running a report. If you cannot generate the report, run the restore command
as follows:
- Open the command window, and change to the following directory:
- JazzSM_HOME/reporting/_uninst/TCR3102Install, Version 3.1.0.2 to Version 3.1.1.
- Run the restore command as follows:
./restore.sh JazzSM_User_Name JazzSM_password
JazzSM_User_Name and JazzSM_password refer to the user ID and password to connect to the Jazz for Service Management application server.
- Open the command window, and change to the following directory:
- Log in to the relevant reporting interface in your environment. See Logging in to the reporting interface. Run the report again.
To restore Cognos on non-Windows, complete the following steps:
- Verify whether the Common Reporting user interface is working
by running a report as follows:
- Open the command window, and change to the following directory:
- JazzSM_HOME/reporting/_uninst/TCR3102Install, if you updated from Version 3.1.0.2 to Version 3.1.1
- Run the restore command as follows:
./restore.sh JazzSM_User_Name JazzSM_password
JazzSM_User_Name and JazzSM_password refer to the user ID and password to connect to the Jazz for Service Management application server.
- Open the command window, and change to the following directory:
- Log in to the relevant reporting interface in your environment. See Logging in to the reporting interface. Run the report again.