IBM Support

DOORS module fails to open in exclusive edit mode results in error "unable to open module ...no such file or directory"

Troubleshooting


Problem

Attempts to open a module exclusive edit in IBM Rational DOORS result in the error "DOORS report Unable to open module '/A Project/Requirements' No such file or directory".

Symptom

A module with a large number of sections is used mostly in shareable edit mode.

You can open the module Read-only , or Shareable-Edit; but not in exclusive edit.

Steps to reproduce:

  1. Login to DOORS
     
  2. Click the Project, or folder, icon that contains the module
     
  3. Click the module icon in the DOORS Explorer window
     
  4. Click File > Open> Exclusive Edit (Ctrl + E)

Expected result: The module should open in Exclusive edit mode.

Actual result: The module will not open in exclusive edit module; however it will open in read only mode, or shareable edit mode. If you attempt to check the database integrity for issue the module is not flagged for any problems.

The full error message is as follows:

DOORS report
Unable to open module '/A Project/Requirements' No such file or directory"
C:\Program Files (x86)\IBM\Rational\DOORS\9.5\data\v6data\20\m00000021.mod\current.ver\s1000005.dtc

image

Cause

This issue has been identified as a product defect under APAR PM50525.

Resolving The Problem

This error indicates that a user session file is corrupted on the database server.

This defect is resolved in IBM Rational DOORS Version 9.4.0.1

WORKAROUND:

The following options can be used to correct this problem:

  • Retrieve the missing file from system backup and insert it into the module current.ver directory

    The advantage of inserting the missing session file is you do not need to restart the database server.
  • Warning these two option should only be performed by Rational Support. Modifications to the files in your DOORS database could result is data corruption and jeapordize your DOORS database.
     
  • Send the session.ixc file to support for repair

    From the module directory listed in the error message provide support the file session.ixc
    Choosing to have support repair the session index file requires you to have all users log out
    and shut down the DOORS database server until the repaired file is returned and inserted
    to replace the existing data file for the module.
     
  • Create a replacement session file
    From the module directory listed in the error message provide support the file session.ixc
    Adjacent session files will be required in order to to create the replacement.
    Your support engineer will identify these files from the session index file.
    No work can be performed in the effected module until the replacement session file is restored
    for the effected module.


Note: Generally the repair is only required for one user session file. However in circumstances where DOORS reports a missing session file for a module- the event that caused this may have effected session files for other users connected to the module. For this situation you may need to perform a successive repair to the index file.

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Document Information

Modified date:
01 May 2020

UID

swg21511831