Troubleshooting
Problem
When starting the IBM Rational ClearQuest Web 7.1 client, the login page shows an empty database repository list. No databases are available to be selected.
Cause
There are multiple possible causes:
- No connections have been defined on ClearQuest Web server.
- ClearQuest Web is not configured correctly.
- There is corruption with the cookies and cache stored by the browser.
Diagnosing The Problem
- Start the ClearQuest client on the ClearQuest Web server. Verify whether you can connect to the intended database.
- Check the SystemErr.log file and see whether this error exists:
- Clear the cookies and cache (temporary internet files) for the browser to force a re-download of the files.
com.ibm.websphere.management.exception.ConnectorException: ADMC0016E: The system cannot create a SOAP connector to connect to host localhost at port 12880.
Resolving The Problem
- If the connection is not working with the client on the ClearQuest Web server, use ClearQuest Maintenance Tool on Windows to define a valid connection or use
cqreg
command on Unix to do so.
- Resolving this problem on custom CM Server configurations
If you use Change Management Server (CM Server) on an stand-alone WebSphere Application Server or change the default port of CM Server, check the parametersTEAM_SERVER_URL
andTEAM_SERVER_SOAP_PORT
in the CqServerConn.properties file. These values must be the same as theWC_defaulthost
andSOAP_CONNECTOR_ADDRESS
settings on the WebSphere Application Server.
You can check the port numbers in WebSphere Application Server Administration Console by going toApplication servers > server1 > Ports
.
The location for the CqServerConn.properties file is:
7.1.0.x:
<install directory>\RationalSDLC\common\CM\profiles\cmprofile\installedApps\<Server Name>CMProfileNode01Cell\RationalClearQuestWeb.ear\CQWebModule.war\WEB-INF\classes
7.1.1.x:
<install directory>\RationalSDLC\common\CM\profiles\cmprofile\installedApps\dfltCell\RationalClearQuestWeb.ear\CQWebModule.war\WEB-INF\classes
7.1.2.x:
<install directory>\RationalSDLC\common\CM\profiles\cmprofile\installedApps\dfltCell\TeamEAR.ear\cqweb.war\WEB-INF\classes
Where <install directory> is by defaultC:\Program Files\IBM
on Windows and/opt/ibm
on Unix.
[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Client (7.1)","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.0.1;7.1.0.2;7.1.1;7.1.1.1;7.1.1.2;7.1.1.3;7.1.1.4;7.1.1.5;7.1.1.6;7.1.2;7.1.2.1;7.1.2.2;7.1.2.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"CM Server","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
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Document Information
Modified date:
23 June 2018
UID
swg21416533