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Invalid report version or not a report file error, when running report in ClearQuest 7.1

Troubleshooting


Problem

This technote explains how to resolve an error, "Invalid report version or not a report file." This can occur when using the IBM Rational ClearQuest 7.1 Eclipse RCP client or Web client.

Symptom

You have the ClearQuest Eclipse RCP client or Web client configured to use the Report Server for Crystal Reports. When running a report, this error occurs:


ClearQuest Report Server Error


An unexpected error occurred during processing.
Invalid report version or not a report file.

Cause

The report format that the report is based on is created with a version of Crystal Reports older than the supported versions.

Resolving The Problem

In order to bring your Report Formats to the required version, perform the these steps:

  1. On a machine with ClearQuest 7.1, install one of the supported versions of Crystal Reports. For a list of supported versions of Crystal Reports see technote 1216371.

  2. Login to ClearQuest and browse the workspace until you find the Report Format that you wish to update to the latest version.

  3. Right-click on the Report Format and select Edit.

  4. In the resulting Window, click Author Report... Crystal Reports will now open and display the Report Format.

  5. After the Report Format opens in Crystal Reports Designer, follow these steps:

    1. Click on the Refresh button.

    2. You will receive this dialog warning:

    3. After clicking OK, you will also receive this dialog:

    4. Click OK again.

  6. From the File menu select Save. You will be asked whether you want to overwrite the Report Format with the latest version. Click Yes and close Crystal Reports.

  7. Back in ClearQuest, on the Edit Report Format window, click OK and confirm committing the changes to the database.


You should now be able to run the report based on the Report Format you have updated.

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Reporting","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.0.1;7.1.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Client - Eclipse RCP","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Client (7.1)","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21375645