IBM Support

Enable tracing for the V2 Base ClearCase-ClearQuest integration

Question & Answer


Question

How can you enable diagnostic tracing for the base (V2) integration between IBM Rational ClearCase and Rational ClearQuest?

Cause

Diagnostic tracing allows for the collection of data used for troubleshooting problems with the V2 integration on both Microsoft Windows and UNIX platforms.

Answer

WINDOWS

To enable V2 tracing on a Windows client, or on the PC that hosts the central config.pl file for the environment, open the config.pl file on the host and configure the parameters listed below. The config.pl file is normally located in the following directories, depending on version.

For 7.1.x:

<InstallDir>\IBM\RationalSDLC\ClearCase\lib\CQCC

For 7.0.x:

<InstallDir>\Rational\ClearCase\lib\CQCC

For 2003.06.x:

<InstallDir>\Rational\ClearCase\lib\perl5\CQCCTrigger\CQCC

Four parameters must be adjusted as follows:



   #------------------------------

    # CQCC_LOG_ERRORS: [ENV]          [DEFAULT: ""]
    # Values: "", INFO, WARN, ERROR, FATAL
     &SetConfigParm("CQCC_LOG_ERRORS", "ERROR");

    #------------------------------
    # CQCC_DEBUG: [ENV]               [DEFAULT: 0]
    # Values: 0 (off), 1(basic), 2(details)
     &SetConfigParm("CQCC_DEBUG", "2");

    #------------------------------
    # CQCC_TIMER: [ENV]               [DEFAULT: 0]
    # &SetConfigParm("CQCC_TIMER", "1");

    #------------------------------
    # CQCC_LOG_OUTPUT: [ENV]          [DEFAULT: OFF]
    # Values: OFF, OVERWRITE, APPEND,
    #    OVERWRITE_THREADS, APPEND_THREADS
     &SetConfigParm("CQCC_LOG_OUTPUT", "OVERWRITE");


Once these are set and the config.pl file saved, reproduce the issue. The log file will be created in one of the following locations:

  1. If CQCC_CACHE_ROOT is enabled, it will be held in the cache folder (referenced in the config.pl file).

    In Windows 7, if CQCC_CACHE_ROOT is set you can redirect the output. For example, if you set:

    &SetConfigParm("CQCC_CACHE_ROOT", "C:\\temp\\mylogs:);

    The cqcc_output.log file will be in this directory:

    C:\temp\mylogs\<Windows login>\<client machine name>\session.main


  2. If caching is not enabled, it will be held in the Windows account's application data folder.

    For Window XP:

    C:\Documents and Settings\<user name>\Application Data\Rational\CQCC

    For Windows 7:

    C:\Users\<user name>\AppData\Roaming\Rational\CQCC



UNIX:

To enable V2 tracing on UNIX-based environments, set the CQCC_DEBUG Environment Variable to 2:

> set CQCC_DEBUG 2


Reproduce the issue and the V2 trace log will be located right in the UNIX account's home directory. To disable tracing, reset the environment variable for 0.

[{"Product":{"code":"SSSTXH","label":"Rational Integrations"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Base ClearCase and ClearQuest","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.1;7.1;7.1.1;7.1.2","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Integrations: IBM","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Integrations: IBM","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21366744