IBM Support

VOBs become inaccessible on UNIX and Linux

Troubleshooting


Problem

This technote identifies an IBM® Rational® ClearCase® 7.x defect relating to the shared memory lock manager on Linux® and UNIX® which may cause your VOBs to become inaccessible and provides you with information on how to workaround the issue.

Symptom


Your VOBs hosted on a ClearCase 7.x server may suddenly become inaccessible.

  • Existing commands run against a VOB (checkout, checkin etc...) will time out.
  • You may also see a variety of time-out errors in db_server log on VOB server host.
  • Attempts to lock a VOB may also fail.

Attempts to describe a VOB may fail with the following error:

cleartool describe vob:/vobs/test
cleartool: Error: Error from VOB database: "/vobs/test".
cleartool: Error: Trouble opening VOB database: "/vobs/test".

These errors are reported in the db_server log:

db_server(15250): Ok: *** db_VISTA database error -901 - system error
db_server(15250): Ok:
db_server(15250): Ok: *** db_VISTA database error -901 - system error
db_server(15250): Error: Error: shared-memory version not set, but there are live logged-in users.
db_server(15250): Error: Login failed for process 15250, almd file /vobstore/vobs/test.vbs/db/almd
db_server(15250): Error: DBMS error in /vobstore/vobs/test.vbs/db.

The view server itself notes the following messages:

Unexpected error in VOB
"host1:/vobstore/vobs/test.vbs" op
vob_ob_get_gen_num:error detected by ClearCase subsystem

Cause


The VOB becomes inaccessible because it is left in a locked state by the lock manager before it dies.

The shared memory lock manager dies (while holding the VOB lock) in an attempt to recover from a mishandled db_server process.




ADVISORY
This is an uncommon condition. There has only been a single instance of this reported to IBM Rational Client Support, thus far, as of the modify date of this technote. You should have no or minimal concerns about this issue with regard to upgrading Rational ClearCase.

Resolving The Problem



This defect has been resolved in the following updates:


7.0.1.1 iFix01 and 7.0.0.2 iFix01


WORKAROUND:

In the event your VOBs become unusable due to this problem, the following procedure should resolve the problem:
  1. Stop ClearCase on the VOB server

    Note: Ensure all ClearCase processes have ended on the VOB server before proceeding to step #2.

  2. Delete (rm) the almd file (and almd.lck) from db directory in VOB storage (.vbs) area of the affected VOB.

  3. Start ClearCase

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Lock Manager","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"7.0.1.1;7.0.1;7.0.0.2;7.0.0.1;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21291817