IBM Support

Trouble was encountered importing CVS elements

Troubleshooting


Problem

This technote explains why attempts to import CVS files into an IBM® Rational® ClearCase® VOB results in the failure of a few (not all) files being imported and provides instructions to resolve the issue.

Cause

Attempts to import (clearimport) CVS files results in the following error for some (not all) files):

clearimport: Error: Trouble invoking extract command.
clearimport: Error: Trouble invoking "cvs -Q get -r1.1 -p
'/userware/schematic_overrides.ample' >
'/tmp/tmp16741/schematic_overrides.ample'".
clearimport: Warning: Trouble importing element
"schematic_overrides.ample".
Closing directories.
clearimport: Error: Trouble was encountered importing the following
elements:
schematic_overrides.ample

The error is the result of a problem with the particular file(s) in the CVS repository.

Resolving The Problem

Verify that the file(s) can be accessed from the CVS repository only.

Run the command :

cvs -Q get -r1.1 -p '/userware/schematic_overrides.ample'

If the files cannot be accessed, it may be necessary to repair the CVS repository.

Once the repair is done, and the files can be extracted from the CVS tool, the file(s) will then import into Rational ClearCase without error.





[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Converter: clearexport_cvs","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF015","label":"IRIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"2002.05.00;2003.06.00;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21146349