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Trouble invoking extract command

Troubleshooting


Problem

This technote explains why attempts to import CVS® files into an IBM® Rational® ClearCase® repository using the []clearexport_cvs[] and []clearimport[] command results in the error []clearimport: Error: Trouble invoking extract command.[] upon import on Microsoft® Windows®.

Cause

Attempts to import elements in to ClearCase after running clearexport_cvs results in the following error:

clearimport: Error: Trouble invoking extract command.
clearimport: Error: Trouble invoking "cvs -Q get -r1.1 -p
"gui\windows\main.cpp"".
clearimport: Warning: Trouble importing element "main.cpp".

Generally this is because the CVSROOT environment variable is not correctly set.

Resolving The Problem

If your CVS repository is at D:\Source\CVSRoot then you should set the variable as follows:

set CVSROOT=:local:D:\Source\CVSRoot


After you set the environment variable, delete the existing cvt_data file and rerun the clearexport_cvs again. After running clearexport_cvs, you will then be able to run clearimport.


Review the ClearCase Command Reference Guide on the topic of clearexport_cvs (cleartool man clearexport_cvs) for more information.



[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Converter: clearexport_cvs","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2003.06.00;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Converter: clearexport_cvs","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21125650